Commit c14c521e authored by Zhu Yi's avatar Zhu Yi Committed by David S. Miller
Browse files

[PATCH] iwlwifi: fix add_station to avoid FW error

There were a few Firmware errors reported the most reproducible
http://bughost.org/bugzilla/show_bug.cgi?id=1471



The root cause is rate_n_flags isn't set anymore. This patch fixes
the problem.

Signed-off-by: default avatarIan Schram <ischram@telenet.be>
Signed-off-by: default avatarZhu Yi <yi.zhu@intel.com>
Signed-off-by: default avatarJohn W. Linville <linville@tuxdriver.com>
parent 46640a8c
......@@ -464,6 +464,7 @@ u8 iwl_add_station(struct iwl_priv *priv, const u8 *addr, int is_ap, u8 flags)
struct iwl_station_entry *station;
unsigned long flags_spin;
DECLARE_MAC_BUF(mac);
u8 rate;
spin_lock_irqsave(&priv->sta_lock, flags_spin);
if (is_ap)
......@@ -507,6 +508,15 @@ u8 iwl_add_station(struct iwl_priv *priv, const u8 *addr, int is_ap, u8 flags)
station->sta.sta.sta_id = index;
station->sta.station_flags = 0;
rate = (priv->phymode == MODE_IEEE80211A) ? IWL_RATE_6M_PLCP :
IWL_RATE_1M_PLCP | priv->hw_setting.cck_flag;
/* Turn on both antennas for the station... */
station->sta.rate_n_flags =
iwl_hw_set_rate_n_flags(rate, RATE_MCS_ANT_AB_MSK);
station->current_rate.rate_n_flags =
le16_to_cpu(station->sta.rate_n_flags);
spin_unlock_irqrestore(&priv->sta_lock, flags_spin);
iwl_send_add_station(priv, &station->sta, flags);
return index;
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment