Commit f09f2189 authored by Avi Kivity's avatar Avi Kivity

Remove support for version 3 ram_load

Version 3 ram_load depends on ram_addrs, which are not stable.  Version 4
was introduced in 0.13 (and RHEL 6), so this means live migration from 0.12
and earlier to 1.1 or later will not work.
Reviewed-by: default avatarAnthony Liguori <aliguori@us.ibm.com>
Signed-off-by: default avatarAvi Kivity <avi@redhat.com>
parent 8fec98b4
......@@ -366,7 +366,7 @@ int ram_load(QEMUFile *f, void *opaque, int version_id)
int flags;
int error;
if (version_id < 3 || version_id > 4) {
if (version_id < 4 || version_id > 4) {
return -EINVAL;
}
......@@ -377,11 +377,7 @@ int ram_load(QEMUFile *f, void *opaque, int version_id)
addr &= TARGET_PAGE_MASK;
if (flags & RAM_SAVE_FLAG_MEM_SIZE) {
if (version_id == 3) {
if (addr != ram_bytes_total()) {
return -EINVAL;
}
} else {
if (version_id == 4) {
/* Synchronize RAM block list */
char id[256];
ram_addr_t length;
......@@ -419,10 +415,7 @@ int ram_load(QEMUFile *f, void *opaque, int version_id)
void *host;
uint8_t ch;
if (version_id == 3)
host = qemu_get_ram_ptr(addr);
else
host = host_from_stream_offset(f, addr, flags);
host = host_from_stream_offset(f, addr, flags);
if (!host) {
return -EINVAL;
}
......@@ -438,10 +431,7 @@ int ram_load(QEMUFile *f, void *opaque, int version_id)
} else if (flags & RAM_SAVE_FLAG_PAGE) {
void *host;
if (version_id == 3)
host = qemu_get_ram_ptr(addr);
else
host = host_from_stream_offset(f, addr, flags);
host = host_from_stream_offset(f, addr, flags);
qemu_get_buffer(f, host, TARGET_PAGE_SIZE);
}
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment