Commit d4af3de2 authored by balrog's avatar balrog
Browse files

gcc32 may well be a 4.x version for a 32bit target, so add an additional...

gcc32 may well be a 4.x version for a 32bit target, so add an additional check, hopefully not too strict.
Probe also gcc-3.3.6 to make Gentoo users happy.


git-svn-id: svn://svn.savannah.nongnu.org/qemu/trunk@3087 c046a42c-6fe2-441c-8c8c-71466251a162
parent 73221b12
......@@ -23,7 +23,7 @@ static="no"
cross_prefix=""
cc="gcc"
gcc3_search="yes"
gcc3_list="gcc-3.4 gcc34 gcc-3.3 gcc33 gcc-3.2 gcc32"
gcc3_list="gcc-3.4 gcc34 gcc-3.3.6 gcc-3.3 gcc33 gcc-3.2 gcc32"
host_cc="gcc"
ar="ar"
make="make"
......@@ -413,7 +413,7 @@ EOF
if test "$gcc3_search" = "yes" ; then
echo "Looking for gcc 3.x"
for compat_cc in $gcc3_list ; do
if "$cross_prefix$compat_cc" --version > /dev/null 2>&1 ; then
if "$cross_prefix$compat_cc" --version 2> /dev/null | fgrep '(GCC) 3.' > /dev/null 2>&1 ; then
echo "Found \"$compat_cc\""
cc="$cross_prefix$compat_cc"
found_compat_cc="yes"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment