• Peter Maydell's avatar
    linux-user: Allow targets to specify a minimum uname release · 4a24a758
    Peter Maydell authored
    
    
    For newer target architectures, glibc can be picky about the kernel
    version: for example, it will not run on an aarch64 system unless
    the kernel reports itself as at least 3.8.0. Accommodate this by
    enhancing the existing support for faking the kernel version so
    that each target can optionally specify a minimum version: if
    the user doesn't force a specific fake version then we will override
    with the minimum required version only if the real host kernel
    version is insufficient.
    
    Use this facility to let aarch64 report a minimum of 3.8.0.
    Signed-off-by: default avatarPeter Maydell <peter.maydell@linaro.org>
    Message-id: 1378235544-22290-21-git-send-email-peter.maydell@linaro.org
    4a24a758
syscall.c 279 KB