Commit aa719874 authored by Christoph Hellwig's avatar Christoph Hellwig Committed by Sagi Grimberg

nvme: fabrics drivers don't need the nvme-pci driver

So select the NVME_CORE symbol instead of depending on BLK_DEV_NVME.
Signed-off-by: 's avatarChristoph Hellwig <hch@lst.de>
Reviewed-by: 's avatarJay Freyensee <james_p_freyensee@linux.intel.com>
Signed-off-by: 's avatarSagi Grimberg <sagi@grimberg.me>
parent 98096d8a
......@@ -31,7 +31,7 @@ config NVME_FABRICS
config NVME_RDMA
tristate "NVM Express over Fabrics RDMA host driver"
depends on INFINIBAND
depends on BLK_DEV_NVME
select NVME_CORE
select NVME_FABRICS
select SG_POOL
help
......
......@@ -15,8 +15,8 @@ config NVME_TARGET
config NVME_TARGET_LOOP
tristate "NVMe loopback device support"
depends on BLK_DEV_NVME
depends on NVME_TARGET
select NVME_CORE
select NVME_FABRICS
select SG_POOL
help
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment