Commit 5eb6a56b authored by David Johnson's avatar David Johnson

Handle newer Ocata packages that run dashboard wsgi under horizon user.

parent 7a1db762
......@@ -1870,7 +1870,14 @@ OPENSTACK_API_VERSIONS = {
EOF
if [ $OSVERSION -eq $OSOCATA ]; then
chown www-data.www-data /var/lib/openstack-dashboard/secret_key
# Original Ocata packages ran dashboard wsgi as www-data; newer
# use horizon.
grep -q user=horizon /etc/apache2/conf-enabled/openstack-dashboard.conf
if [ $? -eq 0 ]; then
chown horizon.www-data /var/lib/openstack-dashboard/secret_key
else
chown www-data.www-data /var/lib/openstack-dashboard/secret_key
fi
elif [ $OSVERSION -ge $OSPIKE ]; then
chown horizon.www-data /var/lib/openstack-dashboard/secret_key
fi
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment