Commit 34aa0d23 authored by David Johnson's avatar David Johnson

Minor bugfixes to 01ec4a98 (docker emulabization of debian:8).

parent bff8f548
......@@ -17,7 +17,7 @@ apt-get install -y --no-install-suggests --no-install-recommends \
gcc make libc-dev byacc libtool-bin 'g++' \
sudo python python-dev libpcap-dev libboost-dev wget patch flex ntp \
zlib1g-dev
dpkg-query -l libssl-dev >& /dev/null
dpkg-query -l libssl-dev
if [ ! $? -eq 0 ]; then
# First try to install it. If there is a problem installing the
# candidate, try to install the version that matches the installed
......@@ -30,7 +30,7 @@ if [ ! $? -eq 0 ]; then
exit 1
fi
version=`dpkg-query -W libssl\* | sed -e 's/^[^\t ]*[\t ]*\([^\t ]*\)[\t ]*.*/\1/'`
apt-get install libssl-dev=$version
apt-get install -y --no-install-suggests --no-install-recommends libssl-dev=$version
if [ ! $? -eq 0 ]; then
echo "ERROR: failed to install libssl-dev=$version!"
exit 1
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment