Minor bugfix to gitlab-ci x86_64-efi path.

3 jobs for master in 3 minutes and 34 seconds
Status Job ID Name Coverage
  Build
failed #2821
emulab-grub2-x86

00:03:34

 
  Deploy
skipped #2823
allowed to fail manual
deploy_production
skipped #2822
deploy_testing
 
Name Stage Failure
failed
emulab-grub2-x86 Build
grub-mknetdir: warning: cannot open directory `/usr/local/share/locale': No such file or directory.
grub-mknetdir: warning: cannot open directory `/usr/local/share/locale': No such file or directory.
Netboot directory for i386-pc created. Configure your DHCP server to point to /tftpboot/grub2pxe-efi-sio2/i386-pc/core.0
Netboot directory for x86_64-efi created. Configure your DHCP server to point to /tftpboot/grub2pxe-efi-sio2/x86_64-efi/core.efi
$ for tdir in /tftpboot/grub2pxe-{bios,native}-* ; do cp -p $tdir/i386-pc/core.0 $tdir/grub2pxe ; rm -rf $tdir/{i386-pc,fonts,locale} ; cd $tdir && ln -s ../grub2.0/locale . && ln -s ../grub2.0/i386-pc . && ln -s ../grub2.0/fonts . ; done
$ for tdir in /tftpboot/grub2pxe-efi-* ; do cp -p $tdir/x86_64-efi/core.efi $tdir/grub2pxe ; rm -rf $tdir/{x86_64-efi,fonts,locale} ; cd $tdir && ln -s ../grub2.0/locale . && ln -s ../grub2.0/x86_64-efi . && ln -s ../grub2.0/fonts . ; done
$ for tdir in /tftpboot/grub2pxe* ; do cp -p emulab/grub.cfg $tdir ; btype=`basename $tdir | cut -d- -f2` ; ctype=`basename $tdir | cut -d- -f3` ; ntype=pxe ; if [ $ctype = "efi" ]; then ntype=efi ; fi ; echo $btype $ctype $ntype ; sed -ie "s/^set console=.*$/set console=$ctype/" $tdir/grub.cfg ; sed -ie "s/^set diskdrivers=.*$/set diskdrivers=$btype/" $tdir/grub.cfg ; sed -ie "s/^set netdrivers=.*$/set netdrivers=$ntype/" $tdir/grub.cfg ; done
cp: cannot stat 'emulab/grub.cfg': No such file or directory
ERROR: Job failed: exit code 1