Commit 97f731ec authored by Mike Hibler's avatar Mike Hibler

"72" and "82" are now the only supported MFS versions.

"62" and "47" are now in the legacy tarball and may or may not work.
parent be7b4d3e
...@@ -25,13 +25,20 @@ sub Install($$$) ...@@ -25,13 +25,20 @@ sub Install($$$)
# Configure can override setting it here. # Configure can override setting it here.
if ($MFSVERSION eq "") { if ($MFSVERSION eq "") {
if ($FBSD_MAJOR > 7 || ($FBSD_MAJOR == 7 && $FBSD_MINOR >= 2)) { if ($FBSD_MAJOR > 8 || ($FBSD_MAJOR == 8 && $FBSD_MINOR >= 2)) {
$MFSVERSION = "82";
}
elsif ($FBSD_MAJOR > 7 || $FBSD_MAJOR == 7 && $FBSD_MINOR >= 2) {
$MFSVERSION = "72"; $MFSVERSION = "72";
} }
else { else {
$MFSVERSION = "62"; $MFSVERSION = "62";
} }
} }
if ($MFSVERSION eq "62" || $MFSVERSION eq "47") {
$MFSTARBALL = "tftpboot-legacy.tar.gz";
$MFSURL = "http://www.emulab.net/downloads/$MFSTARBALL";
}
Phase "mfs", "Setting up MFSs", sub { Phase "mfs", "Setting up MFSs", sub {
my $localfile = "$TFTP_DIR/tftpboot.tar.gz"; my $localfile = "$TFTP_DIR/tftpboot.tar.gz";
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment