Commit 254aed8d authored by David Johnson's avatar David Johnson

No longer apply openssl 1.1.0 patch to clientside for docker ubuntu18 builds.

(This patch was merged in 080bf584 .)
parent e4094ed3
......@@ -17,9 +17,7 @@ apt-get install -y --no-install-suggests --no-install-recommends \
gcc make libc-dev byacc libtool-bin libssl-dev 'g++' zlib1g-dev \
sudo python python-dev libpcap-dev libboost-dev wget patch flex ntp
NEEDPATCH=1
if [ $NEEDPATCH -eq 1 -o -z "$EMULABSRC" ]; then
if [ -z "$EMULABSRC" ]; then
echo "WARNING: missing or unusable EMULABSRC environment variable pointer to src; cloning!"
export EMULABSRC=/tmp/emulab-devel
cd /tmp
......@@ -56,13 +54,6 @@ fi
echo /usr/local/lib > /etc/ld.so.conf.d/pubsub.conf
ldconfig
if [ $NEEDPATCH -eq 1 ]; then
cd $EMULABSRC
wget https://www.emulab.net/downloads/openssl-1.1.0.patch
[ ! $? -eq 0 ] && exit 1
patch -p1 < openssl-1.1.0.patch
fi
mkdir -p /tmp/emulab.obj
cd /tmp/emulab.obj
export NONTP=1
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment