Commit 181e575d authored by Mike Hibler's avatar Mike Hibler

Updates for 11.2 packages.

parent fb96ae69
......@@ -34,7 +34,7 @@ USE_PHP= bz2 ctype curl dom filter gd hash iconv json mcrypt mysql \
#
# Various ports need to agree on what version of apache.
#
.if ${EMULAB_PORTVERSION} == "7.1"
.if (${EMULAB_PORTVERSION} == "7.1" || ${EMULAB_PORTVERSION} == "7.2")
www_apache24_SET= SUEXEC
.MAKEFLAGS+= APACHE_PORT=www/apache24
.MAKEFLAGS+= WITH_SUEXEC=yes
......@@ -44,7 +44,7 @@ www_apache22_SET= SUEXEC
.MAKEFLAGS+= WITH_SUEXEC=yes
.endif
.if ${EMULAB_PORTVERSION} != "7.1"
.if (${EMULAB_PORTVERSION} != "7.1" && ${EMULAB_PORTVERSION} != "7.2")
#
# Use the base version of openssl
#
......
......@@ -12,7 +12,11 @@ OSARCH != /usr/bin/uname -m
EMULAB_PORTVERSION= UNSUPPORTED
.if ${OSMAJOR} >= 11
. if ${OSMINOR} >= 2
EMULAB_PORTVERSION= 7.2
. else
EMULAB_PORTVERSION= 7.1
. endif
.else
. if ${OSMAJOR} >= 10
. if ${OSMINOR} >= 3
......@@ -33,7 +37,7 @@ EMULAB_PORTVERSION= 6.1
# Select PHP and Apache versions
# Fix up some port diffs
#
.if ${EMULAB_PORTVERSION} == "7.1"
.if (${EMULAB_PORTVERSION} == "7.1" || ${EMULAB_PORTVERSION} == "7.2")
DEFAULT_VERSIONS= perl5=5.26 python=2.7 tcltk=8.6 php=5.6 mysql=5.7 apache=2.4
APACHE_PORT=www/apache24
APACHEMODDIR=libexec/apache24
......
......@@ -80,7 +80,7 @@ RUN_DEPENDS+= \
xterm:${PORTSDIR}/x11/xterm \
zsh:${PORTSDIR}/shells/zsh
.if ${PORTVERSION} == "7.1"
.if (${PORTVERSION} == "7.1" || ${PORTVERSION} == "7.2")
RUN_DEPENDS+= \
vim:${PORTSDIR}/editors/vim-console
.else
......
......@@ -30,7 +30,7 @@ USE_PHP= bz2 ctype curl dom filter gd hash iconv json mcrypt mysql \
#
# Various ports need to agree on what version of apache.
#
.if ${EMULAB_PORTVERSION} == "7.1"
.if (${EMULAB_PORTVERSION} == "7.1" || ${EMULAB_PORTVERSION} == "7.2")
www_apache24_SET= SUEXEC
.MAKEFLAGS+= APACHE_PORT=www/apache24
.MAKEFLAGS+= WITH_SUEXEC=yes
......
......@@ -22,7 +22,7 @@ WANT_PHP_MOD= yes
#
# Various ports need to agree on what version of apache.
#
.if ${EMULAB_PORTVERSION} == "7.1"
.if (${EMULAB_PORTVERSION} == "7.1" || ${EMULAB_PORTVERSION} == "7.2")
www_apache24_SET= SUEXEC
.MAKEFLAGS+= APACHE_PORT=www/apache24
.MAKEFLAGS+= WITH_SUEXEC=yes
......@@ -32,7 +32,7 @@ www_apache22_SET= SUEXEC
.MAKEFLAGS+= WITH_SUEXEC=yes
.endif
.if ${EMULAB_PORTVERSION} != "7.1"
.if (${EMULAB_PORTVERSION} != "7.1" && ${EMULAB_PORTVERSION} != "7.2")
#
# Use the base version of openssl
#
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment