Commit 15dce279 authored by Leigh Stoller's avatar Leigh Stoller

Fix for loading an image on a remoteded pg node. This is a kludge, the

notion of "dedicated" is currently a type specific attribute, but we
also have "shared" nodes running on "dedicated" nodes, which messes
everything up. I am not inclined to fix the underlying problem since
Utah is the only site that uses this stuff, and these nodes are slowly
dying out anyway.
parent 272b2e25
......@@ -3823,5 +3823,19 @@ sub SyncTaintStates($)
return $self->SetTaintStates(@taint_states);
}
#
# We have a problem with pcvms on remoteded machines. The typing is
# messed up, not sure what to do yet. Might not be worth fixing since
# Utah is the only site that does this stuff.
#
sub OnRemoteNode($)
{
my ($self) = @_;
my $physhost = $self->GetPhysHost();
return 0
if (!defined($physhost));
return $physhost->isremotenode();
}
# _Always_ make sure that this 1 is at the end of the file...
1;
......@@ -595,7 +595,8 @@ sub osload ($$) {
foreach my $i (@imageidxs) {
# This is passed along so that remote node can request the file.
# Make sure the image object has an access key defined.
if ($nodeobject->isremotenode() && !defined($access_keys[$i])) {
if (($nodeobject->isremotenode() || $nodeobject->OnRemoteNode())
&& !defined($access_keys[$i])) {
$access_keys[$i] = TBGenSecretKey();
$rowref->{'access_key'} = $access_keys[$i];
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment