Commit 826d76b6 authored by Mike Hibler's avatar Mike Hibler
Browse files

Force SNMP v1 when talking to APC units.

The default for the perl SNMP library has apparently changed.
parent 48f736d1
......@@ -46,7 +46,7 @@ sub new($$;$) {
SNMP::initMib(); # parses default list of Mib modules
$SNMP::use_enums = 1; #use enum values instead of only ints
print "Opening SNMP session to $devicename..." if $debug;
my $sess =new SNMP::Session(DestHost => $devicename, Community => 'private');
my $sess =new SNMP::Session(DestHost => $devicename, Community => 'private', Version => '1');
if (!defined($sess)) {
warn("ERROR: Unable to connect to $devicename via SNMP\n");
return undef;
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment