Commit 600e155c authored by Mike Hibler's avatar Mike Hibler
Browse files

Move the dependency on Class::ISA to emulab-boss and not p5-RPC-Async.

It is really a dependency on the version of perl installed.
(cherry picked from commit 544f16c1)
parent 653bd441
......@@ -221,6 +221,11 @@ RUN_DEPENDS+= \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Privileges/Drop.pm:${PORTSDIR}/misc/p5-Privileges-Drop \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/IO/EventMux.pm:${PORTSDIR}/misc/p5-IO-EventMux \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/IO/EventMux/Socket/MsgHdr.pm:${PORTSDIR}/misc/p5-IO-EventMux-Socket-MsgHdr
.if ${PORTVERSION} == "5.0"
# perl 5.12 and beyond wants this
RUN_DEPENDS+= \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Class/ISA.pm:${PORTSDIR}/devel/p5-Class-ISA
.endif
.endif
.if ${OSMAJOR} >= 6
......@@ -245,11 +250,6 @@ RUN_DEPENDS+= \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/LWP/Protocol/https.pm:${PORTSDIR}/www/p5-LWP-Protocol-https
.endif
.if ${OSMAJOR} >= 9
RUN_DEPENDS+= \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Class/ISA.pm:${PORTSDIR}/devel/p5-Class-ISA
.endif
# make sure these get installed
RUN_DEPENDS+= \
${LOCALBASE}/libdata/xorg/libraries:${PORTSDIR}/x11/xorg-libraries \
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment