Commit 5a80bddf authored by David Johnson's avatar David Johnson

Bug Fix: the require statement cannot handle quoted modules anymore.

parent 4a34fa73
...@@ -962,7 +962,7 @@ sub NewType($$) ...@@ -962,7 +962,7 @@ sub NewType($$)
# Not loaded? # Not loaded?
if ($@) { if ($@) {
#print STDERR "module load failed: " . $@ . "\n"; #print STDERR "module load failed: " . $@ . "\n";
eval "require \"libossetup_" . $type . "\""; eval "require libossetup_" . $type;
$newtype = eval { $packname->New($self); }; $newtype = eval { $packname->New($self); };
if ($@) { if ($@) {
# print STDERR "$self NewType($type): module load failed: " . $@ . "\n" # print STDERR "$self NewType($type): module load failed: " . $@ . "\n"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment