Commit 44569ae7 authored by Mike Hibler's avatar Mike Hibler

Take care of a package conflict for FBSD 8.x and rpm-4.

parent f3579fbf
......@@ -1244,6 +1244,11 @@ sub SetupOpsNode($)
system("pkg_delete -r -x mysql-client")
if (-e "/usr/local/bin/mysql");
# XXX 8.2 image is out of sync right now
if ($FBSD_VERSION == 8.2) {
system("pkg_delete -f -x rpm-3");
}
# XXX 7.3 image is out of sync right now
if ($FBSD_VERSION == 7.3) {
system("pkg_delete -f -x python25 -x py25");
......@@ -1863,6 +1868,11 @@ sub SetupBossNode($)
if (-e "/usr/local/bin/mysql");
system("pkg_delete -x net-snmp")
if (-e "/usr/local/include/net-snmp");
# XXX 8.2 image is out of sync right now
if ($FBSD_VERSION == 8.2) {
system("pkg_delete -f -x rpm-3");
}
# XXX 7.3 image is out of sync right now
if ($FBSD_VERSION == 7.3) {
......@@ -2474,6 +2484,11 @@ sub SetupOpsJail()
system("pkg_delete -r -x mysql-client")
if (-e "/usr/local/bin/mysql");
# XXX 8.2 image is out of sync right now
if ($FBSD_VERSION == 8.2) {
system("pkg_delete -f -x rpm-3");
}
# XXX 7.3 image is out of sync right now
if ($FBSD_VERSION == 7.3) {
system("pkg_delete -f -x python25 -x py25");
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment